Please choose the phantasia client you'd like to play on and click on it's name below. Macintosh Netscape users can only use the 1.02 client. I recommend the 1.18 client for everyone else.



Home | The Game | The Rules | Game Info